ONLINE
STORE
"ASK THE BACH MAN"
FORUM
PARTS, SERVICE,
& INFORMATION
CATALOGS AND
BROCHURES

Welcome, Guest. Please login or register.
Did you miss your activation email?
January 19, 2018, 11:13:49 AM
Home Help Search Login Register
News: Check out the photo gallery link above or >click here< to see photos of recently announced products!
+  Bachmann Message Board
|-+  Discussion Boards
| |-+  Williams by Bachmann
| | |-+  Union Pacific FP-45 Problem
« previous next »
Pages: [1] Print
Author Topic: Union Pacific FP-45 Problem  (Read 2294 times)
Karl Reichenbach

View Profile
« on: January 24, 2016, 01:10:02 AM »

Received a new Williams Union Pacific FP-45 for Christmas.  Runs great out of the box but the horn does not work.  Opened it up and the speaker was in 2 pieces.  Called customer service about the speaker.  Was told to e-mail them a proof of purchase and they would send me a new speaker.

It has been a month and I have not heard from them, and have not received a new speaker.

What's up with this.  This is not the kind of service I have received from Bachmann in the past.

Karl
Logged
Chessie1971


View Profile
« Reply #1 on: January 26, 2016, 02:22:30 AM »

Karl keep calling them they are hard to get a hold of don't leave mess or email they won't answer you but call til you get a person on the phone.
Logged
Karl Reichenbach

View Profile
« Reply #2 on: January 26, 2016, 02:59:02 PM »

Chessie,

I did get an e-mail from the service manager today.
Hope this takes care of my speaker problem.
Karl
Logged
Karl Reichenbach

View Profile
« Reply #3 on: February 02, 2016, 12:18:56 AM »

I did get my new speaker today.  Also got a new sound board along with it. This is the kind of customer service I have been used to from Bachmann.  Now all I have to do is install them.

Karl
« Last Edit: February 02, 2016, 12:21:20 AM by Karl Reichenbach » Logged
Chessie1971


View Profile
« Reply #4 on: February 02, 2016, 12:32:55 AM »

Thats great Karl! Grin
Logged
Karl Reichenbach

View Profile
« Reply #5 on: February 05, 2016, 12:09:39 AM »

Installed the new speaker and board.  Engine runs great and the horn sounds great.  Thanks Williams by Bachmann for backing up your products.

Karl
Logged
Pages: [1] Print 
« previous next »
Jump to:  
Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!