Bachmann Message Board

Discussion Boards => HO => Topic started by: kingmarco on October 06, 2017, 08:36:55 PM



Title: Bachmann ALCO 2-6-0 w/ Soundtraxx don't move
Post by: kingmarco on October 06, 2017, 08:36:55 PM
Hi, I recently bought an HO Echo Valley Express Kit with a Loco ALCO 2-6-0 Steam DCC with sound, and when I set it up the machine worked fine but it stopped suddenly, I moved or pushed and it worked again, which made me think that it was a problem with the tracks or layout, now that I made and Layout more strong, but happened the same.

In parallel a bought another loco an ALCO RS-3 DCC with Sound to compare, the a 2-6-0 Steam continued stopping suddenly, and the RS-3 never stopped, which I assumed was a problem of Alco 2-6-0 Steam.

Now and to increase the problem, the alco 2-6-0 Steam does not move at all, the lights, sounds, and whistle works, but does not move.

Any idea what might be happening or how to solve it ???


Title: Re: Bachmann ALCO 2-6-0 w/ Soundtraxx don't move
Post by: Yardmaster on October 06, 2017, 11:21:59 PM
Sounds like perhaps a loose wire connection on the circuit board. You can take the tender shell off and check for any loose connections or call the Bachmann service department who will be glad to help.


Title: Re: Bachmann ALCO 2-6-0 w/ Soundtraxx don't move
Post by: Trainman203 on October 12, 2017, 09:49:22 AM
Train sets and also model engines can be in stock a very, very long time (years) before being sold .  All of the electric contact points can oxidize.  Bachmann steam engines are great but nearly every one I've ever bought ( over 50) needs a radical wheel and contact wiper cleaning before consistently running without stalling.