Bachmann Message Board

Discussion Boards => Large => Topic started by: macappin on April 26, 2009, 08:58:25 AM



Title: 2-6-6-2 QSI and MTS help please
Post by: macappin on April 26, 2009, 08:58:25 AM
I installed a QSI sound module in my 2-6-6-2 and it does not appear to work with my MTS system. Does anyone know if they are incompatible. I was aware that the sound system in the 3 truck Shays would not work with MTS and I wonder whether this also applies to QSI modules.

I know I need to ditch the MTS but I am reluctant to throw away the investment.

Thanks for any help.


Title: Re: 2-6-6-2 QSI and MTS help please
Post by: Nick Hall on April 28, 2009, 06:01:32 AM
Hi

I have no direct experience of the new Mallet, but I suspect the problem lies in the track voltage coming from the MTS control unit. This can be 23-25 volts, which is too high for the installed DCC chip, which then overloads and shuts down.

The solution for this is to place a series of bridge rectifiers between the control unit and the track (see www.atlasrr.com/voltage.htm or www.tonystrains.com/technews/soundtraxx_heats.htm). The rectifiers reduce the voltage reaching the track (which should be below 21 volts) and allow the chip to work normally.

I have a Bachmann K-27 with a QSI sound chip, plus 3-truck Shays which work and sound great on my MTS system. One other thing - the MTS system only supports 14 speed steps, so the CV29 address in the chip has to be given a value of 4 - the QSI chip is probably set up for 28/128 speed steps.

Good luck!

Nick.