ONLINE
STORE
"ASK THE BACH MAN"
FORUM
PARTS, SERVICE,
& INFORMATION
CATALOGS AND
BROCHURES

Welcome, Guest. Please login or register.
Did you miss your activation email?
August 10, 2020, 12:32:49 PM
Home Help Search Login Register
News: Check out the photo gallery link above or >click here< to see photos of recently announced products!
+  Bachmann Message Board
|-+  Discussion Boards
| |-+  Williams by Bachmann
| | |-+  Hudson smoke unit
« previous next »
Pages: [1] Print
Author Topic: Hudson smoke unit  (Read 1585 times)
NSthoroughbred

View Profile
« on: October 06, 2009, 10:27:57 AM »

I bought a scale Hudson last week,  and put the prescribed amount of smoke fluid in.    The smoke unit worked fine for a day or two,  I refilled the smoke unit as smoke started to taper off.    Suddenly the smoke unit started only making noises and  ceased to produce smoke, sputtered, spraying fluid in a fine mist all over my new loco.    Any tips, advice?

« Last Edit: October 06, 2009, 10:38:00 AM by NSthoroughbred » Logged
the Bach-man
Administrator


View Profile
« Reply #1 on: October 06, 2009, 11:34:51 PM »

Dear NS,
Sometimes a brief puff down the stack will free the blockage.
Have fun!
the Bach-man
Logged
NSthoroughbred

View Profile
« Reply #2 on: October 11, 2009, 11:02:24 AM »

I have now tried to clear the smoke unit with puffs into the stack, yet I fear this smoke unit has ceased to operate. 
Logged
Pages: [1] Print 
« previous next »
Jump to:  
Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!