ONLINE
STORE
"ASK THE BACH MAN"
FORUM
PARTS, SERVICE,
& INFORMATION
CATALOGS AND
BROCHURES

Welcome, Guest. Please login or register.
Did you miss your activation email?
July 12, 2020, 10:42:29 PM
Home Help Search Login Register
News: Please read the Forum Code of Conduct   >>Click Here <<
+  Bachmann Message Board
|-+  Discussion Boards
| |-+  Thomas & Friends
| | |-+  Edward's smokin'!
« previous next »
Pages: 1 [2] Print
Author Topic: Edward's smokin'!  (Read 7942 times)
MetaDude27
Guest
« Reply #15 on: November 25, 2011, 03:25:51 PM »

Thanks for the info. I also wanted to send in my Annie coach because I accidently chipped two corners of her roof off. However, since she is a piece of rolling stock, I'm not sure what would be required to have her repaired (e.g. a repair fee of some sort). Has anyone ever sent in rolling stock for repairs? If so, what did you have to do?

That I don't know.  I looked online to see if they sell replacement parts but I only see listings for engines not rolling stock.  That may not be covered under warranty.  I suggest you call The Bach-mann and see what he says.  Chances are you can buy a replacement roof for her for just a few dollars.
-Art

Yeah, that's probably what I'll do. Thanks for your input.
Logged
PasqualeCS96

View Profile
« Reply #16 on: November 25, 2011, 04:31:19 PM »

You know its wierd, I got my Edward at the World's Greatest Hobby on tour when it was here in Cleveland about three-four years ago. It ran very well but then it started jerking and just stopped all together. I sent him inwhen I hot him back, he went bad again last year sometime and I sent him back again. But the second time I got him back quicker so Im wondering if they just replaced him. But, anyways he's fine now.
Logged
Anthony P2

this Doctor doesn't shut railways down


View Profile
« Reply #17 on: November 25, 2011, 10:43:27 PM »

My Edward started to slow down last year. This time last year he stoped working for a week then cooperated for a month. I replaced him this year around april and works fine.
Logged
MetaDude27
Guest
« Reply #18 on: November 26, 2011, 12:12:12 PM »

My Edward didn't smoke, but for some reason he started going slower than usual. At first he would eventually snap out of it and go his regular speed, but one day he stopped working altogether. I also noticed that when Edward and another engine are put on the same track, neither of them will run, so I assume he has a short-circuit of some kind.
Logged
Calebtrain

Hello!


View Profile WWW
« Reply #19 on: November 26, 2011, 01:35:28 PM »

Yeah. That's exactly what happend to mine. But there was a singe of smoke. Weird huh?  Huh?
Logged

http://www.youtube.com/user/Calebtrain

I am always willing to help the best way I can. Smiley
therailwayinspector

Crane's Eye View


View Profile WWW
« Reply #20 on: November 26, 2011, 03:02:48 PM »

Mine alternates between both, though he seemed to be ok for most of this afternoon.....
Logged

Steam, Diesel? It's All The Same.
Creator Of Thomas The Model Adventures
PasqualeCS96

View Profile
« Reply #21 on: November 26, 2011, 04:50:53 PM »

Well I guess all models just vary when it come down to it.
Logged
Pages: 1 [2] Print 
« previous next »
Jump to:  
Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!