ONLINE
STORE
"ASK THE BACH MAN"
FORUM
PARTS, SERVICE,
& INFORMATION
CATALOGS AND
BROCHURES

Welcome, Guest. Please login or register.
Did you miss your activation email?
November 17, 2019, 09:08:11 PM
Home Help Search Login Register
News: Please read the Forum Code of Conduct   >>Click Here <<
+  Bachmann Message Board
|-+  Discussion Boards
| |-+  Large
| | |-+  Got A "New" Train
« previous next »
Pages: [1] Print
Author Topic: Got A "New" Train  (Read 279 times)
RkyGriz
Guest
« on: March 09, 2019, 07:14:43 PM »

Hi guys! I just received a Bachmann Golden Classics Limited Edition South Pacific Coast train set that I bought on Ebay. In spite of a few cosmetic imperfections(someone added their idea of a paint scheme to the cars and back of the locomotive cab), and a cracked main gear( which ,so far, doesn't seem to effect the running ability of the locomotive), it is in pretty decent condition considering that it was built sometime between 1994 to 1998. Check out my video here:
https://youtu.be/GsEj6GZHd18
And here's the stationary steam sound:
https://youtu.be/ru8DcTa-4fg
I've only run it back and forth with the tender attached on my desktop so far, but I've determined that it still runs well, in spite of the cracked gear,and that the sound works. And ,yes, it does make the steam sound when it's sitting still!
Also, for those who may be wondering or interested, this has the Bachmann Version 3 chassis. It has a smooth bottom plate, brush-style contacts, the wheels can not be moved by hand, and no gear box, so replacing the cracked gear is out of the question, I do plan on purchasing an Anniversary chassis for this locomotive shortly...
Later,
Andrew
« Last Edit: March 09, 2019, 08:09:09 PM by RkyGriz » Logged
Pages: [1] Print 
« previous next »
Jump to:  
Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!