ONLINE
STORE
"ASK THE BACH MAN"
FORUM
PARTS, SERVICE,
& INFORMATION
CATALOGS AND
BROCHURES

Welcome, Guest. Please login or register.
Did you miss your activation email?
September 22, 2019, 06:25:42 AM
Home Help Search Login Register
News: Please read the Forum Code of Conduct   >>Click Here <<
+  Bachmann Message Board
|-+  Discussion Boards
| |-+  N
| | |-+  Switch Problems and Track Type Changes
« previous next »
Pages: [1] Print
Author Topic: Switch Problems and Track Type Changes  (Read 326 times)
TheHighwayStar


View Profile
« on: June 05, 2019, 04:35:16 PM »

I'm in sort of a dilemma here re: my track.

My layout, a small one (3x6 ft.) uses Tomix sectional track with roadbed, except for, thus far, two Atlas Snap-Switches (I don't have any of the Tomix brand switches, but I do have a fair amount of Snap-Track.)
Have done all the usual stuff to try to isolate the main reason why my locos keep stalling and occasionally derailing on these. Rails are clean as a whistle all around. Electrical connections–rail joiners AND power–are all spot-on. Swapped out one with a brand-new SS, same problem. Both locos have no problems running on the rest of the line.
Right now I'm operating the switches manually; I haven't wired the machines yet. I did notice that the points themselves aren't particularly responsive, if that's the right word, when the points are changed.

Should I move on to a different brand of switch, Bachmann's perhaps?
Logged
tannenba

View Profile
« Reply #1 on: July 03, 2019, 09:25:41 PM »

Atlas switches have plastic frogs.  Short wheelbase and most steam locos stutter or stall on them.
Logged
Pages: [1] Print 
« previous next »
Jump to:  
Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!