ONLINE
STORE
"ASK THE BACH MAN"
FORUM
PARTS, SERVICE,
& INFORMATION
CATALOGS AND
BROCHURES

Welcome, Guest. Please login or register.
Did you miss your activation email?
February 25, 2020, 02:52:46 PM
Home Help Search Login Register
News: Check out the photo gallery link above or >click here< to see photos of recently announced products!
+  Bachmann Message Board
|-+  Discussion Boards
| |-+  Large
| | |-+  2 truck shay problem
« previous next »
Pages: [1] Print
Author Topic: 2 truck shay problem  (Read 247 times)
ntrainman2001

View Profile
« on: August 29, 2019, 02:25:48 PM »

Just acquired  2 truck shay from a friends estate. Wanted to make sure it worked and when I put it on the track, the lights worked as well as the sound but it did not move. Sounded like something in the front was slipping. turned it off and when I went to turn it back on, I got nothing. Got power to tracks but nothing to the loco. appears to be a short. Can service help me to get this running and completely check it out , since I live 35 min. from factory if I drop it off? no paperwork was included with this. If I didn't take it, it would have gone in the trash!!   Thanks, Mike
Logged
the Bach-man
Administrator


View Profile
« Reply #1 on: August 29, 2019, 09:49:37 PM »

Dear Mike,
You may certainly call the service department and make an appointment and drop it off.
Calling ahead is the key!
Good luck!the Bach-man
Logged
ntrainman2001

View Profile
« Reply #2 on: August 30, 2019, 08:22:10 AM »

thank you
Logged
Pages: [1] Print 
« previous next »
Jump to:  
Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!