Please read the Forum Code of Conduct   >>Click Here <<

Main Menu

Ez app sound

Started by bobvsf, February 12, 2021, 09:57:17 PM

Previous topic - Next topic


I bought a Alco RS3 today to give the EZ App a try. I downloaded the app on my Iphone X . I put  the loco on the tracks and it said on my phone updating firmwear. I then paired the loco with the app and it runs great. Only problem is I cant get the sounds going!  I tried increasing it on the app and on the phone itself but nothing. What am I doing wrong?  Thanks
MRC Prodigy Advanced2
p.s. it doesnt run on my DC track at all
Update- I was able to use the app on my ipad and it ran/made sound in both DCC and Dc. Now to get it to sound on mt iphone xs
My ipad has bluetooth 4. My iphone newer bluetooth 5. Is that a problem?


Since nobody at Bachmann replied, I guess ez app sound doesnt work if you have bluetooth 5.

Country Joe

I am surprised and disappointed that no one from Bachmann answered you.

the Bach-man

Dear Bob,
Sorry I missed that.  Of course, I can't even get my phone to work...
I'll see what I can find out.
the Bach-man


Update. After 6 days of trying it finally worked today!  I  didnt do anything different. The sound function just started!  Why it didnt for 5 days is a mystery. Will update tomorrow
Update 2/19. It still works, but spotty at times. The loco suddenly becomes "unavailable. ". I have to close out the app and turn off track power and wait a min. Then it works again. But when I leave and come back it starts out ok but suddenly becomes unavailable again. Odd, but at least I now how to reset

the Bach-man

Dear Bob,
Today was a snow day in Philly-
I'll still follow up...
the Bach-man


Similar but different problem. Yesterday my loco ran fine but only with diesel sounds. Steam setting still played diesel. Today—runs fine but no sounds whatsoever. Light, direction, and throttle only.

Oops, turned on the sound on my phone. Now all works as intended but I don't understand yesterday's problem.


ez app HO engine #6864 has lost its audio.  No bells or horns play through my Ipad.  The engine still functions with the ez app controls but no sound effects any more.     Sound effects worked fine  at first.   I have tried rebooting the ipad and reinstalling the EZ app from the app store and checking the 16 volt power source wired as DCC directly to the rails.  There is  now only one bluetooth  device,  my 6th generation ipad  connected to the train.  We did have the EZ app installed on our Iphone.  It also worked fine initially with sound  but no-longer.   To make sure there were not two conflicting  bluetooth devices  I uninstalled the EZ app from the cell phone.  The sound issue  still persists.
Any Suggestions?
Thanks Den


Please disregard my post about sound issues and the EZ app.  I am finding that our iphone works just fine with no lack of sound issues using the EZ App.  All functions with the app work.  I think the lack of sound using our iPad is a problem within the iPad's settings or preferences.  Thanks anyway!