ONLINE
STORE
"ASK THE BACH MAN"
FORUM
PARTS, SERVICE,
& INFORMATION
CATALOGS AND
BROCHURES

Welcome, Guest. Please login or register.
Did you miss your activation email?
December 19, 2018, 06:17:25 AM
Home Help Search Login Register
News: Please read the Forum Code of Conduct   >>Click Here <<
+  Bachmann Message Board
|-+  Discussion Boards
| |-+  General Discussion
| | |-+  Service
« previous next »
Pages: [1] Print
Author Topic: Service  (Read 1829 times)
BugNerd

View Profile
« on: February 21, 2007, 10:36:00 AM »

I returned a N&W Class-J on Jan. 11, 07.  It smoked its tender and the arms on the drive wheels seemed really loose.

Last week and again today, I was not able to reach the service department.  The phone continues to ring endlessly.  I called 215 number and was transferred to customer service, but told the computer systems were down and that they were short-handed. 

This is my first locomotive and so obviously my first return.  How can I get the status of the return and is there a way to be notified when it's returned?

Thank you
Logged
SteamGene

View Profile
« Reply #1 on: February 21, 2007, 10:39:08 AM »

This is a busy time for sevice at Bachmann.  You will probably get a new locomotive.   I'm afraid that it might not arrive to you until the middle of March.  If you want, call again and ask for Bridget.
Gene
Logged

Chief Brass Hat
Virginia Tidewater and Piedmont Railroad
"Only coal fired steam locomotives"
johnk

View Profile
« Reply #2 on: February 21, 2007, 01:22:18 PM »

Dear Bug Nerd- Read pg. 2 thread entitled WARRANTY REPAIR- you will see you are not alone.

Last week I got back my engine back from service. I sent it in on Nov. 16.

After waiting 3 months , I was happy to get it. The note said they replaced the engine rather than repair it. I took it out of the box - put it on the track and bingo- it didn't work. Somehow they put my defective one in the box instead of the replacement.
Logged
BugNerd

View Profile
« Reply #3 on: February 21, 2007, 01:42:48 PM »

Thanks for pointing me toward that thread.  I had also emailed them last week with no response.
Logged
johnk

View Profile
« Reply #4 on: February 21, 2007, 01:50:00 PM »

you're welcome BugNerd

Also found thread - Question from the new guy - also on page 2

It seems they have a lot of problems this time of year.
Logged
Pages: [1] Print 
« previous next »
Jump to:  
Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!